Pages

Monday, May 9, 2016

Error while installing X2Go Server on Red Hat Enterprise Linux

Configuration:
Red Hat Enterprise Linux Server 7.2 (Maipo) base installation (Server with GUI) with EPEL enabled.

Issue:
Dependencies errors while trying to install X2Go server.

Error:

# yum install x2goserver
(...)
Error: Package: x2goserver-4.0.1.19-6.el7.x86_64 (epel)
           Requires: perl(Capture::Tiny)
Error: Package: x2goserver-4.0.1.19-6.el7.x86_64 (epel)
           Requires: perl(Config::Simple)
Error: Package: x2goserver-4.0.1.19-6.el7.x86_64 (epel)
           Requires: perl(File::Which)


Solution:
Required packages (perl-Capture-Tiny, perl-Config-Simple and perl-File-Which) are not provided by EPEL for EL7 but are available in "Red Hat Enterprise Linux 7 Server - Optional (RPMs)" repository that needs to be enabled.

yum-config-manager --enable rhel-7-server-optional-rpms

No comments:

Post a Comment